about summary refs log tree commit diff
path: root/users/tazjin/nixos/modules/physical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/modules/physical.nix')
-rw-r--r--users/tazjin/nixos/modules/physical.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/tazjin/nixos/modules/physical.nix b/users/tazjin/nixos/modules/physical.nix
index 92b22112d4f4..baae1b6b5bfe 100644
--- a/users/tazjin/nixos/modules/physical.nix
+++ b/users/tazjin/nixos/modules/physical.nix
@@ -114,5 +114,14 @@ in
       mosh.enable = true;
       ssh.startAgent = true;
     };
+
+    # Automatically collect garbage from the Nix store.
+    services.depot.automatic-gc = {
+      enable = true;
+      interval = "1 hour";
+      diskThreshold = 16; # GiB
+      maxFreed = 50; # GiB
+      preserveGenerations = "14d";
+    };
   };
 }