about summary refs log tree commit diff
path: root/users/tazjin/nixos/modules/physical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/modules/physical.nix')
-rw-r--r--users/tazjin/nixos/modules/physical.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/users/tazjin/nixos/modules/physical.nix b/users/tazjin/nixos/modules/physical.nix
index f2e44c479a..1f8b694381 100644
--- a/users/tazjin/nixos/modules/physical.nix
+++ b/users/tazjin/nixos/modules/physical.nix
@@ -1,5 +1,5 @@
 # Default configuration settings for physical machines that I use.
-{ pkgs, depot, ... }:
+{ lib, pkgs, depot, ... }:
 
 let
   pass-otp = pkgs.pass.withExtensions (e: [ e.pass-otp ]);
@@ -84,6 +84,9 @@ in
     fwupd.enable = true;
   };
 
+  # Disable the broken NetworkManager-wait-online.service
+  systemd.services.NetworkManager-wait-online.enable = lib.mkForce false;
+
   programs = {
     fish.enable = true;
     mosh.enable = true;