about summary refs log tree commit diff
path: root/users/tazjin/nixos/frog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/frog/default.nix')
-rw-r--r--users/tazjin/nixos/frog/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/users/tazjin/nixos/frog/default.nix b/users/tazjin/nixos/frog/default.nix
index 991abcbec4..f3e75a2420 100644
--- a/users/tazjin/nixos/frog/default.nix
+++ b/users/tazjin/nixos/frog/default.nix
@@ -194,6 +194,12 @@ in depot.lib.fix(self: {
     };
   };
 
+  # Run a Buildkite agent for depot builds
+  services.buildkite-agents.frog = {
+    enable = true;
+    tokenPath = "/etc/secrets/buildkite-token";
+  };
+
   environment.systemPackages =
     # programs from the depot
     (with depot; [