about summary refs log tree commit diff
path: root/users/tazjin/nixos/camden/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/nixos/camden/default.nix')
-rw-r--r--users/tazjin/nixos/camden/default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/users/tazjin/nixos/camden/default.nix b/users/tazjin/nixos/camden/default.nix
index aae1427f67..d8c439b4f4 100644
--- a/users/tazjin/nixos/camden/default.nix
+++ b/users/tazjin/nixos/camden/default.nix
@@ -124,6 +124,11 @@ in lib.fix(self: {
   programs.fish.enable = true;
   programs.mosh.enable = true;
 
+  fonts = {
+    fonts = [ nixpkgs.jetbrains-mono ];
+    fontconfig.defaultFonts.monospace = [ "JetBrains Mono" ];
+  };
+
   environment.systemPackages =
     # programs from the depot
     (with depot; [
@@ -138,6 +143,7 @@ in lib.fix(self: {
       curl
       direnv
       emacs26-nox
+      fswebcam
       git
       gnupg
       google-cloud-sdk
@@ -147,6 +153,7 @@ in lib.fix(self: {
       pciutils
       restic
       ripgrep
+      screen
     ]);
 
   users = {
@@ -154,7 +161,7 @@ in lib.fix(self: {
     users.tazjin = {
       isNormalUser = true;
       uid = 1000;
-      extraGroups = [ "git" "wheel" "quassel" ];
+      extraGroups = [ "git" "wheel" "quassel" "video" ];
       shell = nixpkgs.fish;
     };
 
@@ -258,7 +265,6 @@ in lib.fix(self: {
     recommendedGzipSettings = true;
     recommendedProxySettings = true;
 
-
     appendConfig = ''
       rtmp_auto_push on;
       rtmp {