about summary refs log tree commit diff
path: root/users/tazjin/dt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/dt/CMakeLists.txt')
-rw-r--r--users/tazjin/dt/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/tazjin/dt/CMakeLists.txt b/users/tazjin/dt/CMakeLists.txt
new file mode 100644
index 0000000000..85b659fea8
--- /dev/null
+++ b/users/tazjin/dt/CMakeLists.txt
@@ -0,0 +1,16 @@
+# -*- mode: cmake; -*-
+cmake_minimum_required(VERSION 3.16)
+project(dt)
+add_executable(dt dt.cc)
+find_package(absl REQUIRED)
+
+target_link_libraries(dt
+  absl::flags
+  absl::flags_parse
+  absl::hash
+  absl::time
+  absl::strings
+  farmhash
+)
+
+install(TARGETS dt DESTINATION bin)