about summary refs log tree commit diff
path: root/users/tazjin/dotfiles/waybar/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/dotfiles/waybar/config.nix')
-rw-r--r--users/tazjin/dotfiles/waybar/config.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/users/tazjin/dotfiles/waybar/config.nix b/users/tazjin/dotfiles/waybar/config.nix
new file mode 100644
index 000000000000..e65edabe7d19
--- /dev/null
+++ b/users/tazjin/dotfiles/waybar/config.nix
@@ -0,0 +1,51 @@
+{ depot, pkgs, ... }:
+
+let
+  launcher = "${pkgs.xfce4-appfinder}/bin/xfce4-appfinder --disable-server";
+in
+{
+  mainBar = {
+    layer = "top";
+    position = "bottom";
+    modules-left = [ "image#start" "custom/start" ];
+
+    "image#start" = {
+      path = "${depot.third_party.chicago95}/share/icons/Chicago95/panel/24/start-here.png";
+      size = 24;
+      on-click = "xfce4-appfinder --disable-server";
+    };
+
+    "custom/start" = {
+      format = " Start";
+      on-click = "xfce4-appfinder --disable-server";
+    };
+
+    modules-right = [ "pulseaudio" "backlight" "battery" "tray" "clock" ];
+
+    pulseaudio = {
+      on-click = "pavucontrol";
+      # Font "Awesome" speaker icons can't be made to render, I don't care why, emoji time.
+      format = "{volume}% ๐ŸŽง";
+      format-muted = "{volume}% ๏‡ถ";
+    };
+
+    battery = {
+      format = "{capacity}% {icon}";
+      format-icons = [ "๏‰„" "๏‰ƒ" "๏‰‚" "๏‰" "๏‰€" ];
+    };
+
+    backlight = {
+      format = "{percent}% {icon}";
+      format-icons = [ "๏ƒซ" ];
+      on-scroll-up = "light -A 1";
+      on-scroll-down = "light -U 1";
+    };
+
+    clock.format-alt = "{:%a, %d. %b  %H:%M}";
+
+    tray = {
+      icon-size = 20;
+      spacing = 10;
+    };
+  };
+}