about summary refs log tree commit diff
path: root/users/tazjin/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/blog/default.nix')
-rw-r--r--users/tazjin/blog/default.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/users/tazjin/blog/default.nix b/users/tazjin/blog/default.nix
index fd2f38839a..c65b5cb50b 100644
--- a/users/tazjin/blog/default.nix
+++ b/users/tazjin/blog/default.nix
@@ -4,6 +4,20 @@ with depot.nix.yants;
 
 let
   inherit (builtins) hasAttr filter;
+
+  blogConfig = {
+    name = "tazjin's blog";
+
+    footer = ''
+      <p class="footer">
+        <a class="uncoloured-link" href="https://tazj.in">homepage</a>
+        |
+        <a class="uncoloured-link" href="https://cs.tvl.fyi/">code</a>
+      </p>
+      <p class="lod">ಠ_ಠ</p>
+    '';
+  };
+
   inherit (depot.web.blog) post includePost renderPost;
 
   posts = filter includePost (list post (import ./posts.nix));
@@ -12,7 +26,7 @@ let
     mkdir -p $out
 
     ${lib.concatStringsSep "\n" (map (post:
-      "cp ${renderPost post} $out/${post.key}.html"
+      "cp ${renderPost blogConfig post} $out/${post.key}.html"
     ) posts)}
   '';