about summary refs log tree commit diff
path: root/users/tazjin/aoc2020/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/aoc2020/default.nix')
-rw-r--r--users/tazjin/aoc2020/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/users/tazjin/aoc2020/default.nix b/users/tazjin/aoc2020/default.nix
index ebb6e7b0c0..5989224f8d 100644
--- a/users/tazjin/aoc2020/default.nix
+++ b/users/tazjin/aoc2020/default.nix
@@ -11,12 +11,12 @@ let
   getDay = f: head (matchSolution f);
 
   solutionFiles = filter (e: dir."${e}" == "regular" && isSolution e) (attrNames dir);
-  solutions = map (f: let day = getDay f; in {
-    name = day;
-    value = depot.nix.writeElispBin {
-      name = "aoc2020";
+  solutions = map (f: let day = getDay f; in depot.nix.writeElispBin {
+      name = day;
       deps = p: with p; [ dash s ht p.f ];
       src = ./. + ("/" + f);
-    };
   }) solutionFiles;
-in listToAttrs solutions
+in depot.third_party.symlinkJoin {
+  name = "aoc2020";
+  paths = solutions;
+}