about summary refs log tree commit diff
path: root/users/tazjin/aoc2019/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/tazjin/aoc2019/default.nix')
-rw-r--r--users/tazjin/aoc2019/default.nix22
1 files changed, 13 insertions, 9 deletions
diff --git a/users/tazjin/aoc2019/default.nix b/users/tazjin/aoc2019/default.nix
index ce3146d1f7..a1798f4001 100644
--- a/users/tazjin/aoc2019/default.nix
+++ b/users/tazjin/aoc2019/default.nix
@@ -11,12 +11,16 @@ let
   getDay = f: head (matchSolution f);
 
   solutionFiles = filter (e: dir."${e}" == "regular" && isSolution e) (attrNames dir);
-  solutions = map (f: let day = getDay f; in {
-    name = day;
-    value = depot.nix.writeElispBin {
-      name = "aoc2019";
-      deps = p: with p; [ dash s ht ];
-      src = ./. + ("/" + f);
-    };
-  }) solutionFiles;
-in listToAttrs solutions
+  solutions = map
+    (f:
+      let day = getDay f; in {
+        name = day;
+        value = depot.nix.writeElispBin {
+          name = "aoc2019";
+          deps = p: with p; [ dash s ht ];
+          src = ./. + ("/" + f);
+        };
+      })
+    solutionFiles;
+in
+listToAttrs solutions