about summary refs log tree commit diff
path: root/users/sterni/machines/ingeborg/http/code.sterni.lv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/sterni/machines/ingeborg/http/code.sterni.lv.nix')
-rw-r--r--users/sterni/machines/ingeborg/http/code.sterni.lv.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/users/sterni/machines/ingeborg/http/code.sterni.lv.nix b/users/sterni/machines/ingeborg/http/code.sterni.lv.nix
index fd4975ed1d59..3b080b9dc8b5 100644
--- a/users/sterni/machines/ingeborg/http/code.sterni.lv.nix
+++ b/users/sterni/machines/ingeborg/http/code.sterni.lv.nix
@@ -167,10 +167,22 @@ in
 {
   imports = [
     ./nginx.nix
-    ./fcgiwrap.nix
   ];
 
   config = {
+    services.fcgiwrap.cgit = {
+      process = {
+        user = "http";
+        group = "http";
+      };
+      # Default value doesn't work as documented
+      # https://github.com/NixOS/nixpkgs/pull/318599/files#r1673885083
+      socket = {
+        user = "http";
+        group = "http";
+      };
+    };
+
     services.nginx.virtualHosts."${virtualHost}" = {
       enableACME = true;
       forceSSL = true;
@@ -185,7 +197,7 @@ in
           fastcgi_param    QUERY_STRING    $args;
           fastcgi_param    HTTP_HOST       $server_name;
           fastcgi_param    CGIT_CONFIG     ${cgitConfig};
-          fastcgi_pass     unix:${toString config.services.fcgiwrap.socketAddress};
+          fastcgi_pass     unix:${toString config.services.fcgiwrap.cgit.socket.address};
         }
       '';
     };