about summary refs log tree commit diff
path: root/users/multi/home/configs/whitby.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/multi/home/configs/whitby.nix')
-rw-r--r--users/multi/home/configs/whitby.nix66
1 files changed, 66 insertions, 0 deletions
diff --git a/users/multi/home/configs/whitby.nix b/users/multi/home/configs/whitby.nix
new file mode 100644
index 0000000000..665c11bb87
--- /dev/null
+++ b/users/multi/home/configs/whitby.nix
@@ -0,0 +1,66 @@
+{ depot, pkgs, ... }:
+
+let
+  nixpkgs = import pkgs.nixpkgsSrc {};
+in
+
+{
+  programs = {
+    home-manager = {
+      enable = true;
+      path = toString nixpkgs.home-manager.src;
+    };
+
+    bash = {
+      enable = true;
+      initExtra = ''
+        bind '"\e[5~":history-search-backward'
+        bind '"\e[6~":history-search-forward'
+
+        PS1="[\\u@\\h:\\w]\\\$ "
+
+        _Z_CMD=d
+        source ~/.z.sh
+      '';
+    };
+
+    tmux = {
+      enable = true;
+      terminal = "tmux-256color";
+      escapeTime = 50;
+      extraConfig = ''
+        bind-key -n C-S-Left swap-window -t -1
+        bind-key -n C-S-Right swap-window -t +1
+      '';
+    };
+
+    vim = {
+      enable = true;
+      extraConfig = "set mouse=";
+    };
+  };
+
+  home.sessionVariables = {
+    NIX_PATH =
+      "nixpkgs=${pkgs.nixpkgsSrc}:" +
+      "depot=${depot.depotPath}";
+    HOME_MANAGER_CONFIG = "${depot.depotPath}/users/multi/whitby/home-manager.nix";
+    EDITOR = "vim";
+  };
+
+  home.packages = [
+    nixpkgs.lsof
+    nixpkgs.strace
+    nixpkgs.file
+    nixpkgs.pciutils
+  ];
+
+  home.file = {
+    z = {
+      source = builtins.fetchurl "https://raw.githubusercontent.com/rupa/z/9f76454b32c0007f20b0eae46d55d7a1488c9df9/z.sh";
+      target = ".z.sh";
+    };
+  };
+
+  home.stateVersion = "20.03";
+}