about summary refs log tree commit diff
path: root/users/grfn/xanthous/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/shell.nix')
-rw-r--r--users/grfn/xanthous/shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/grfn/xanthous/shell.nix b/users/grfn/xanthous/shell.nix
new file mode 100644
index 0000000000..29a4952106
--- /dev/null
+++ b/users/grfn/xanthous/shell.nix
@@ -0,0 +1,16 @@
+{ pkgs ? (import ../../../. {}).third_party, ... }:
+
+(pkgs.haskellPackages.extend (pkgs.haskell.lib.packageSourceOverrides {
+  xanthous = pkgs.gitignoreSource ./.;
+})).shellFor {
+  packages = p: [p.xanthous];
+  withHoogle = true;
+  doBenchmark = true;
+  buildInputs = with pkgs.haskellPackages; [
+    cabal-install
+    ghc-prof-flamegraph
+    hp2pretty
+    hlint
+    haskell-language-server
+  ];
+}