about summary refs log tree commit diff
path: root/users/grfn/xanthous/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/shell.nix')
-rw-r--r--users/grfn/xanthous/shell.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/users/grfn/xanthous/shell.nix b/users/grfn/xanthous/shell.nix
deleted file mode 100644
index 2c41cb4aa8..0000000000
--- a/users/grfn/xanthous/shell.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-let
-  depot = import ../../../. { };
-  inherit (depot) third_party;
-  pkgs = third_party.nixpkgs;
-in
-
-(pkgs.haskell.packages.ghc8107.extend (pkgs.haskell.lib.packageSourceOverrides {
-  xanthous = third_party.gitignoreSource ./.;
-})).shellFor {
-  packages = p: [ p.xanthous ];
-  withHoogle = true;
-  doBenchmark = true;
-  buildInputs = (with pkgs.haskell.packages.ghc8107; [
-    cabal-install
-    ghc-prof-flamegraph
-    hp2pretty
-    hlint
-    haskell-language-server
-    cabal2nix
-  ]) ++ (with pkgs; [
-    qpdf
-  ]);
-}