about summary refs log tree commit diff
path: root/users/grfn/xanthous/server/docker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/server/docker.nix')
-rw-r--r--users/grfn/xanthous/server/docker.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/grfn/xanthous/server/docker.nix b/users/grfn/xanthous/server/docker.nix
new file mode 100644
index 000000000000..a62943c2b077
--- /dev/null
+++ b/users/grfn/xanthous/server/docker.nix
@@ -0,0 +1,19 @@
+{ depot ? import ../../../.. {}
+, pkgs ? depot.third_party.nixpkgs
+, ...
+}:
+
+let
+  inherit (depot.users.grfn) xanthous;
+  xanthous-server = xanthous.server;
+in pkgs.dockerTools.buildLayeredImage {
+  name = "xanthous-server";
+  tag = "latest";
+  contents = [ xanthous xanthous-server ];
+  config = {
+    Cmd = [
+      "${xanthous-server}/bin/xanthous-server"
+      "--xanthous-binary-path" "${xanthous}/bin/xanthous"
+    ];
+  };
+}