about summary refs log tree commit diff
path: root/users/grfn/xanthous/server/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/server/Cargo.toml')
-rw-r--r--users/grfn/xanthous/server/Cargo.toml29
1 files changed, 0 insertions, 29 deletions
diff --git a/users/grfn/xanthous/server/Cargo.toml b/users/grfn/xanthous/server/Cargo.toml
deleted file mode 100644
index d4a064beb6..0000000000
--- a/users/grfn/xanthous/server/Cargo.toml
+++ /dev/null
@@ -1,29 +0,0 @@
-[package]
-name = "xanthous-server"
-version = "0.1.0"
-edition = "2018"
-
-[dependencies]
-clap = { version = "3.0", features = [ "derive", "env" ] }
-color-eyre = "0.5.11"
-eyre = "0.6.5"
-thrussh = "0.33.5"
-thrussh-keys = "0.21.0"
-tracing = "0.1.29"
-tracing-subscriber = "0.2.25"
-metrics = "0.17.0"
-metrics-exporter-prometheus = "0.6.1"
-futures = "0.3.17"
-libc = "0.2.103"
-nix = "0.23.0"
-
-# Pins for rust 1.55 (2018 edition) until we have 1.56 in nixpkgs-unstable
-pbkdf2 = "<0.9"
-base64ct = "<1.2"
-
-[dependencies.tokio]
-version = "1.13"
-features = ["rt", "rt-multi-thread", "macros", "net", "process", "fs", "signal"]
-
-[dev-dependencies]
-tempfile = "3.2.0"