about summary refs log tree commit diff
path: root/users/grfn/xanthous/pkg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/pkg.nix')
-rw-r--r--users/grfn/xanthous/pkg.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/grfn/xanthous/pkg.nix b/users/grfn/xanthous/pkg.nix
new file mode 100644
index 0000000000..16a6500866
--- /dev/null
+++ b/users/grfn/xanthous/pkg.nix
@@ -0,0 +1,16 @@
+{ depot ? (import ../../../. {})
+, pkgs ? depot.third_party.nixpkgs
+, ... }:
+
+let
+  ignore = depot.third_party.gitignoreSource.gitignoreFilter ./.;
+in import (pkgs.haskellPackages.haskellSrc2nix {
+  name = "xanthous";
+  src = builtins.path {
+    name = "xanthous-source";
+    path = ./.;
+    filter = path: type: ignore path type
+      || builtins.baseNameOf path == "package.yaml";
+  };
+  extraCabal2nixOptions = "--hpack";
+})