about summary refs log tree commit diff
path: root/users/grfn/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/default.nix')
-rw-r--r--users/grfn/xanthous/default.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/users/grfn/xanthous/default.nix b/users/grfn/xanthous/default.nix
deleted file mode 100644
index 049c92fb4c9c..000000000000
--- a/users/grfn/xanthous/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ depot ? (import ../../../. { })
-, pkgs ? depot.third_party.nixpkgs
-, ...
-}:
-
-let
-  ignore = depot.third_party.gitignoreSource.gitignoreFilter ./.;
-  src = builtins.path {
-    name = "xanthous-source";
-    path = ./.;
-    filter = path: type:
-      !(type == "directory" && builtins.baseNameOf path == "server")
-      && !(type == "directory" && builtins.baseNameOf path == "docs")
-      && (ignore path type
-      || builtins.baseNameOf path == "package.yaml");
-  };
-  # generated by cabal2nix
-  basePkg = pkgs.haskell.packages.ghc8107.callPackage ./pkg.nix { };
-in
-
-pkgs.haskell.lib.overrideCabal basePkg (default: {
-  inherit src;
-  version = "canon";
-  configureFlags = [
-    "--ghc-option=-Wall --ghc-option=-Werror"
-  ] ++ (default.configureFlags or [ ]);
-})