about summary refs log tree commit diff
path: root/users/grfn/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/default.nix')
-rw-r--r--users/grfn/xanthous/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/users/grfn/xanthous/default.nix b/users/grfn/xanthous/default.nix
index c0eca446c9..e8a1eb14eb 100644
--- a/users/grfn/xanthous/default.nix
+++ b/users/grfn/xanthous/default.nix
@@ -1,6 +1,7 @@
-{ depot ? (import ../../../. {})
+{ depot ? (import ../../../. { })
 , pkgs ? depot.third_party.nixpkgs
-, ... }:
+, ...
+}:
 
 let
   ignore = depot.third_party.gitignoreSource.gitignoreFilter ./.;
@@ -11,7 +12,7 @@ let
       !(type == "directory" && builtins.baseNameOf path == "server")
       && !(type == "directory" && builtins.baseNameOf path == "docs")
       && (ignore path type
-          || builtins.baseNameOf path == "package.yaml");
+      || builtins.baseNameOf path == "package.yaml");
   };
   # generated by cabal2nix
   basePkg = pkgs.haskellPackages.callPackage ./pkg.nix { };
@@ -22,5 +23,5 @@ pkgs.haskell.lib.overrideCabal basePkg (default: {
   version = "canon";
   configureFlags = [
     "--ghc-option=-Wall --ghc-option=-Werror"
-  ] ++ (default.configureFlags or []);
+  ] ++ (default.configureFlags or [ ]);
 })