about summary refs log tree commit diff
path: root/users/grfn/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/xanthous/default.nix')
-rw-r--r--users/grfn/xanthous/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/users/grfn/xanthous/default.nix b/users/grfn/xanthous/default.nix
index 1316ff583f..90dd5870d7 100644
--- a/users/grfn/xanthous/default.nix
+++ b/users/grfn/xanthous/default.nix
@@ -7,8 +7,10 @@ let
   src = builtins.path {
     name = "xanthous-source";
     path = ./.;
-    filter = path: type: ignore path type
-      || builtins.baseNameOf path == "package.yaml";
+    filter = path: type:
+      !(type == "directory" && builtins.baseNameOf path == "server")
+      && (ignore path type
+          || builtins.baseNameOf path == "package.yaml");
   };
   # generated by cabal2nix
   basePkg = pkgs.haskellPackages.callPackage ./pkg.nix { };