about summary refs log tree commit diff
path: root/users/grfn/system/system/machines/mugwump.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/system/machines/mugwump.nix')
-rw-r--r--users/grfn/system/system/machines/mugwump.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/users/grfn/system/system/machines/mugwump.nix b/users/grfn/system/system/machines/mugwump.nix
index c5b60284d4..05b78ce517 100644
--- a/users/grfn/system/system/machines/mugwump.nix
+++ b/users/grfn/system/system/machines/mugwump.nix
@@ -153,7 +153,7 @@ with lib;
     zone = "gws.fyi";
     protocol = "cloudflare";
     username = "root@gws.fyi";
-    passwordFile = "/run/agenix/ddclient-password";
+    passwordFile = config.age.secretsDir + "/ddclient-password";
     quiet = true;
   };
 
@@ -161,7 +161,7 @@ with lib;
 
   security.acme.certs."metrics.gws.fyi" = {
     dnsProvider = "cloudflare";
-    credentialsFile = "/run/agenix/cloudflare";
+    credentialsFile = config.age.secretsDir + "/cloudflare";
     webroot = mkForce null;
   };
 
@@ -272,8 +272,8 @@ with lib;
       value = {
         inherit name;
         enable = true;
-        tokenPath = "/run/agenix/buildkite-token";
-        privateSshKeyPath = "/run/agenix/buildkite-ssh-key";
+        tokenPath = config.age.secretsDir + "/buildkite-token";
+        privateSshKeyPath = config.age.secretsDir + "/buildkite-ssh-key";
         runtimePackages = with pkgs; [
           docker
           nix