about summary refs log tree commit diff
path: root/users/grfn/system/system/iso.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/system/iso.nix')
-rw-r--r--users/grfn/system/system/iso.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/grfn/system/system/iso.nix b/users/grfn/system/system/iso.nix
new file mode 100644
index 0000000000..9fa8e7ec7e
--- /dev/null
+++ b/users/grfn/system/system/iso.nix
@@ -0,0 +1,18 @@
+{ depot, lib, pkgs, ... }:
+
+let
+  configuration = { ... }: {
+    imports = [
+      (pkgs.path + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
+      (pkgs.path + "/nixos/modules/installer/cd-dvd/channel.nix")
+    ];
+
+    networking.networkmanager.enable = true;
+    networking.useDHCP = false;
+    networking.firewall.enable = false;
+    networking.wireless.enable = lib.mkForce false;
+  };
+in
+(depot.third_party.nixos {
+  inherit configuration;
+}).config.system.build.isoImage