about summary refs log tree commit diff
path: root/users/grfn/system/system/iso.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/system/iso.nix')
-rw-r--r--users/grfn/system/system/iso.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/users/grfn/system/system/iso.nix b/users/grfn/system/system/iso.nix
deleted file mode 100644
index 398145f1cfab..000000000000
--- a/users/grfn/system/system/iso.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ depot, lib, pkgs, ... }:
-
-let
-  configuration = { ... }: {
-    imports = [
-      (pkgs.path + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
-      (pkgs.path + "/nixos/modules/installer/cd-dvd/channel.nix")
-    ];
-
-    networking.networkmanager.enable = true;
-    networking.useDHCP = false;
-    networking.firewall.enable = false;
-    networking.wireless.enable = lib.mkForce false;
-
-    # TODO(grfn): enabling this (in the minimal profile) fails the iso build,
-    # since gtk+3 needs to be built which fails due to cairo without xlibs
-    environment.noXlibs = false;
-  };
-in
-(depot.third_party.nixos {
-  inherit configuration;
-}).config.system.build.isoImage