about summary refs log tree commit diff
path: root/users/grfn/system/home/platforms/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/platforms/darwin.nix')
-rw-r--r--users/grfn/system/home/platforms/darwin.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/users/grfn/system/home/platforms/darwin.nix b/users/grfn/system/home/platforms/darwin.nix
deleted file mode 100644
index f98b80f269..0000000000
--- a/users/grfn/system/home/platforms/darwin.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
-  config = {
-    home.packages = with pkgs; [
-      coreutils
-      gnupg
-      pinentry_mac
-    ];
-
-    home.activation.linkApplications = lib.hm.dag.entryAfter [ "writeBoundary" ] ''
-      $DRY_RUN_CMD ln -sf $VERBOSE_ARG \
-        ~/.nix-profile/Applications/* ~/Applications/
-    '';
-
-    programs.zsh.initExtra = ''
-      export NIX_PATH=$HOME/.nix-defexpr/channels:$NIX_PATH
-
-      if [[ "$TERM" == "alacritty" ]]; then
-        export TERM="xterm-256color"
-      fi
-    '';
-  };
-}