about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/lib/zshFunctions.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/lib/zshFunctions.nix')
-rw-r--r--users/grfn/system/home/modules/lib/zshFunctions.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/users/grfn/system/home/modules/lib/zshFunctions.nix b/users/grfn/system/home/modules/lib/zshFunctions.nix
deleted file mode 100644
index 228dc6379fd6..000000000000
--- a/users/grfn/system/home/modules/lib/zshFunctions.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
-  options = {
-    programs.zsh.functions = mkOption {
-      description = "An attribute set that maps function names to their source";
-      default = { };
-      type = with types; attrsOf (either str path);
-    };
-  };
-
-  config.programs.zsh.initExtra = concatStringsSep "\n" (
-    mapAttrsToList
-      (name: funSrc: ''
-        function ${name}() {
-          ${funSrc}
-        }
-      '')
-      config.programs.zsh.functions
-  );
-}