about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/i3.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/i3.nix')
-rw-r--r--users/grfn/system/home/modules/i3.nix30
1 files changed, 19 insertions, 11 deletions
diff --git a/users/grfn/system/home/modules/i3.nix b/users/grfn/system/home/modules/i3.nix
index 7bd371e117..27a21496ea 100644
--- a/users/grfn/system/home/modules/i3.nix
+++ b/users/grfn/system/home/modules/i3.nix
@@ -39,15 +39,23 @@ in
   };
 
   config =
-    let decorationFont = "MesloLGSDZ ${toString config.system.machine.i3FontSize}"; in
-    {
-      home.packages = with pkgs; [
-        rofi
-        rofi-pass
-        python38Packages.py3status
-        i3lock
-        i3status
-        dconf # for gtk
+    let
+      fontName = "MesloLGSDZ";
+      fontSize = config.system.machine.i3FontSize;
+      fonts = {
+        names = [ fontName ];
+        size = fontSize * 1.0;
+      };
+      decorationFont = "${fontName} ${toString fontSize}";
+    in
+      {
+        home.packages = with pkgs; [
+          rofi
+          rofi-pass
+          python38Packages.py3status
+          i3lock
+          i3status
+          dconf # for gtk
 
         # Screenshots
         maim
@@ -176,7 +184,7 @@ in
               ]
             );
 
-          fonts = [ decorationFont ];
+          inherit fonts;
 
           colors = with solarized; rec {
             focused = {
@@ -296,7 +304,7 @@ in
                 '';
               in
               "py3status -c ${i3status-conf}";
-            fonts = [ decorationFont ];
+            inherit fonts;
             position = "top";
             colors = with solarized; rec {
               background = base03;