about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/development/rust.nix')
-rw-r--r--users/grfn/system/home/modules/development/rust.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/users/grfn/system/home/modules/development/rust.nix b/users/grfn/system/home/modules/development/rust.nix
index 9ed42f5d2d..105a23bc83 100644
--- a/users/grfn/system/home/modules/development/rust.nix
+++ b/users/grfn/system/home/modules/development/rust.nix
@@ -3,13 +3,15 @@
 let
   inherit (config.lib) depot;
 in
+
+with lib;
+
 {
 
   home.packages = with pkgs; [
     rustup
     cargo-edit
     cargo-expand
-    cargo-rr
     cargo-udeps
     cargo-bloat
     sccache
@@ -24,6 +26,8 @@ in
     coz
     inferno
     hotspot
+  ] ++ optionals (stdenv.isLinux) [
+    cargo-rr
   ];
 
   programs.zsh.shellAliases = {