about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/development/rust.nix')
-rw-r--r--users/grfn/system/home/modules/development/rust.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/users/grfn/system/home/modules/development/rust.nix b/users/grfn/system/home/modules/development/rust.nix
index 4ae5bc3bcc..95a9ad1a91 100644
--- a/users/grfn/system/home/modules/development/rust.nix
+++ b/users/grfn/system/home/modules/development/rust.nix
@@ -1,18 +1,28 @@
 { config, lib, pkgs, ... }:
 
-
+let
+  inherit (config.lib) depot;
+in
 {
+
   home.packages = with pkgs; [
     rustup
     rust-analyzer
     cargo-edit
     cargo-expand
-    cargo-flamegraph
     cargo-rr
     cargo-udeps
     cargo-bloat
     sccache
     evcxr
+
+    depot.users.grfn.pkgs.cargo-hakari
+    depot.users.grfn.pkgs.cargo-nextest
+
+    # benchmarking+profiling
+    cargo-criterion
+    cargo-flamegraph
+    coz
   ];
 
   programs.zsh.shellAliases = {