about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/readyset.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/development/readyset.nix')
-rw-r--r--users/grfn/system/home/modules/development/readyset.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/users/grfn/system/home/modules/development/readyset.nix b/users/grfn/system/home/modules/development/readyset.nix
index e3e84a31af..9bb9d6644d 100644
--- a/users/grfn/system/home/modules/development/readyset.nix
+++ b/users/grfn/system/home/modules/development/readyset.nix
@@ -8,7 +8,9 @@
   home.packages = with pkgs; [
     # This goes in $PATH so I can run it from rofi and parent to my WM
     (writeShellScriptBin "dotclip" "xclip -out -selection clipboard | dot -Tpng | feh -")
-    (buildGoModule rec {
+
+    # TODO(grfn): rain fails to build with Go >=1.18, investigate.
+    (buildGo117Module rec {
       pname = "rain";
       version = "1.2.0";
 
@@ -21,6 +23,7 @@
 
       vendorSha256 = "16bx7cjh5cq9zlis8lf28i016avgqf3j9fmcvkqzd8db2vxpqx3v";
     })
+
     awscli2
     amazon-ecr-credential-helper
   ];