about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/readyset.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/development/readyset.nix')
-rw-r--r--users/grfn/system/home/modules/development/readyset.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/users/grfn/system/home/modules/development/readyset.nix b/users/grfn/system/home/modules/development/readyset.nix
new file mode 100644
index 000000000000..9acc338e423a
--- /dev/null
+++ b/users/grfn/system/home/modules/development/readyset.nix
@@ -0,0 +1,34 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ./rust.nix
+  ];
+
+  home.packages = with pkgs; [
+    # These go in $PATH so I can run it from rofi and parent to my WM
+    (writeShellScriptBin "dotclip" "xclip -out -selection clipboard | dot -Tpng | feh -")
+    (writeShellScriptBin "dotcontroller" "curl -s localhost:6033/graph | dot -Tpng | feh -")
+
+    rain
+    awscli2
+    ssm-session-manager-plugin
+    amazon-ecr-credential-helper
+    postgresql_14
+  ];
+
+  programs.zsh.shellAliases = {
+    "tf" = "terraform";
+  };
+
+  home.file.".docker/config.json".text = builtins.toJSON {
+    credHelpers = {
+      "305232526136.dkr.ecr.us-east-2.amazonaws.com" = "ecr-login";
+      "public.ecr.aws" = "ecr-login";
+    };
+  };
+
+  programs.zsh.functions."purge_deployment" = ''
+    for key in $(http :8500/v1/kv/$1 keys==true | jq -r .'[]'); do http DELETE ":8500/v1/kv/$key"; done
+  '';
+}