about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/readyset.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/grfn/system/home/modules/development/readyset.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/users/grfn/system/home/modules/development/readyset.nix b/users/grfn/system/home/modules/development/readyset.nix
new file mode 100644
index 0000000000..e9782e84f0
--- /dev/null
+++ b/users/grfn/system/home/modules/development/readyset.nix
@@ -0,0 +1,12 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ./rust.nix
+  ];
+
+  home.packages = with pkgs; [
+    # This goes in $PATH so I can run it from rofi and parent to my WM
+    (writeShellScriptBin "dotclip" "xclip -out -selection clipboard | dot -Tpng | feh -")
+  ];
+}