about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/desktop.nix')
-rw-r--r--users/grfn/system/home/modules/desktop.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/users/grfn/system/home/modules/desktop.nix b/users/grfn/system/home/modules/desktop.nix
new file mode 100644
index 0000000000..67123b8082
--- /dev/null
+++ b/users/grfn/system/home/modules/desktop.nix
@@ -0,0 +1,29 @@
+{ config, lib, pkgs, ... }:
+
+# Things that only work in the presence of a linux desktop environment
+
+{
+  imports = [
+    ./i3.nix
+    ./obs.nix
+    ./games.nix
+  ];
+
+  home.packages = with pkgs; [
+    ntfy
+  ];
+
+  programs.zsh.initExtra = ''
+    eval "$(${pkgs.ntfy}/bin/ntfy shell-integration)"
+  '';
+
+  services.syncthing.tray.enable = true;
+
+  gtk = {
+    enable = true;
+    gtk3.bookmarks = [
+      "file:///home/grfn/code"
+      "file:///home/grfn/notes"
+    ];
+  };
+}