about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/modules/desktop.nix')
-rw-r--r--users/grfn/system/home/modules/desktop.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/users/grfn/system/home/modules/desktop.nix b/users/grfn/system/home/modules/desktop.nix
deleted file mode 100644
index cab3b658e0..0000000000
--- a/users/grfn/system/home/modules/desktop.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-# Things that only work in the presence of a linux desktop environment
-
-{
-  imports = [
-    ./i3.nix
-    ./obs.nix
-    ./games.nix
-  ];
-
-  home.packages = with pkgs; [
-    (ntfy.override {
-      # Slack support is broken as of 2023-06-15
-      withSlack = false;
-    })
-    (writeShellApplication {
-      name = "edit-input";
-
-      runtimeInputs = [ xdotool xclip ];
-      text = ''
-        set -euo pipefail
-
-        sleep 0.2
-        xdotool key ctrl+a ctrl+c
-        xclip -out -selection clipboard > /tmp/EDIT
-        emacsclient -c /tmp/EDIT
-        xclip -in -selection clipboard < /tmp/EDIT
-        sleep 0.2
-        xdotool key ctrl+v
-        rm /tmp/EDIT
-      '';
-    })
-  ];
-
-  services.syncthing.tray.enable = true;
-
-  gtk = {
-    enable = true;
-    gtk3.bookmarks = [
-      "file:///home/grfn/code"
-      "file:///home/grfn/notes"
-    ];
-  };
-}