about summary refs log tree commit diff
path: root/users/grfn/system/home/machines/yeren.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/machines/yeren.nix')
-rw-r--r--users/grfn/system/home/machines/yeren.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/users/grfn/system/home/machines/yeren.nix b/users/grfn/system/home/machines/yeren.nix
deleted file mode 100644
index 9a7a561b5e62..000000000000
--- a/users/grfn/system/home/machines/yeren.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-{ pkgs, lib, config, ... }:
-
-let
-  inherit (builtins) pathExists;
-  laptopKeyboardId = "5";
-in
-
-{
-  imports = [
-    ../platforms/linux.nix
-    ../modules/common.nix
-    ../modules/desktop.nix
-    ../modules/development/agda.nix
-    ../modules/development/readyset.nix
-    ../modules/development/ocaml.nix
-  ] ++ (lib.optional (pathExists ../modules/private.nix) ../modules/private.nix);
-
-  # for when hacking
-  programs.home-manager.enable = true;
-  home.stateVersion = "20.03";
-
-  system.machine = {
-    wirelessInterface = "wlp0s20f3";
-    i3FontSize = 9;
-  };
-
-  home.packages = with pkgs; [
-    zoom-us
-    slack
-    mariadb
-    graphviz
-    gnuplot
-    mypaint
-    xdot
-    tdesktop
-    subsurface
-    discord
-    steam
-  ];
-
-  systemd.user.services.laptop-keyboard = {
-    Unit = {
-      Description = "Swap caps+escape and alt+super, but only on the built-in laptop keyboard";
-      After = [ "graphical-session-pre.target" ];
-      PartOf = [ "graphical-session.target" ];
-    };
-
-    Install = { WantedBy = [ "graphical-session.target" ]; };
-
-    Service = {
-      Type = "oneshot";
-      RemainAfterExit = true;
-      ExecStart = (
-        "${pkgs.xorg.setxkbmap}/bin/setxkbmap "
-        + "-device ${laptopKeyboardId} "
-        + "-option caps:swapescape "
-        + "-option compose:ralt "
-        + "-option altwin:swap_alt_win"
-      );
-    };
-  };
-
-  xsession.windowManager.i3.config.keybindings.F9 = "exec lock";
-
-  xdg.mimeApps.defaultApplications."x-scheme-handler/tg" =
-    "telegramdesktop.desktop";
-
-  programs.zsh.shellAliases = {
-    "graph" = "curl -s localhost:6033/graph | dot -Tpng | feh -";
-  };
-
-  programs.ssh.matchBlocks."grfn-dev" = {
-    host = "grfn-dev";
-    forwardAgent = true;
-    user = "ubuntu";
-  };
-}