about summary refs log tree commit diff
path: root/users/grfn/system/home/machines/yeren.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/machines/yeren.nix')
-rw-r--r--users/grfn/system/home/machines/yeren.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/users/grfn/system/home/machines/yeren.nix b/users/grfn/system/home/machines/yeren.nix
index 38bab02995..cb36c89736 100644
--- a/users/grfn/system/home/machines/yeren.nix
+++ b/users/grfn/system/home/machines/yeren.nix
@@ -1,6 +1,7 @@
 { pkgs, lib, config, ... }:
 
 let
+  inherit (builtins) pathExists;
   laptopKeyboardId = "5";
 in
 
@@ -9,7 +10,7 @@ in
     ../platforms/linux.nix
     ../modules/common.nix
     ../modules/development/readyset.nix
-  ];
+  ] ++ (lib.optional (pathExists ../modules/private.nix) ../modules/private.nix);
 
   # for when hacking
   programs.home-manager.enable = true;