about summary refs log tree commit diff
path: root/users/grfn/system/home/machines/roswell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/machines/roswell.nix')
-rw-r--r--users/grfn/system/home/machines/roswell.nix63
1 files changed, 0 insertions, 63 deletions
diff --git a/users/grfn/system/home/machines/roswell.nix b/users/grfn/system/home/machines/roswell.nix
deleted file mode 100644
index 135477b12ddf..000000000000
--- a/users/grfn/system/home/machines/roswell.nix
+++ /dev/null
@@ -1,63 +0,0 @@
-{ pkgs, lib, config, ... }:
-
-let
-  inherit (builtins) pathExists;
-in
-
-{
-  imports = [
-    ../platforms/linux.nix
-    ../modules/shell.nix
-    ../modules/development.nix
-    ../modules/emacs.nix
-    ../modules/vim.nix
-    ../modules/development/readyset.nix
-    ../modules/tmux.nix
-  ] ++ (lib.optional (pathExists ../modules/private.nix) ../modules/private.nix);
-
-  home.packages = with pkgs; [
-    # System utilities
-    bat
-    htop
-    killall
-    bind
-    zip
-    unzip
-    tree
-    nmap
-    bc
-    pv
-
-    # Security
-    gnupg
-    keybase
-    openssl
-
-    # Nix things
-    nixfmt
-    nix-prefetch-github
-    nixpkgs-review
-    cachix
-
-    # ReadySet stuff
-    nodejs
-    mysql80
-
-    (writeShellScriptBin "xdg-open" "echo xdg-open: \"$@\"")
-  ];
-
-  programs.password-store.enable = true;
-
-  programs.home-manager.enable = true;
-  home.stateVersion = "20.03";
-
-  xsession.enable = lib.mkForce false;
-
-  services.lorri.enable = true;
-
-  programs.direnv = {
-    enable = true;
-    enableBashIntegration = true;
-    enableZshIntegration = true;
-  };
-}