about summary refs log tree commit diff
path: root/users/grfn/system/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/default.nix')
-rw-r--r--users/grfn/system/home/default.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/users/grfn/system/home/default.nix b/users/grfn/system/home/default.nix
index 1efba3f3c1..6221df95c3 100644
--- a/users/grfn/system/home/default.nix
+++ b/users/grfn/system/home/default.nix
@@ -5,13 +5,16 @@ with lib;
 rec {
   home = confPath: (import "${pkgs.home-manager.src}/modules" {
     inherit pkgs;
-    configuration = { config, lib, ... }: {
-      imports = [confPath];
-
-      _module.args.pkgs = mkForce
-        (import pkgs.path (filterAttrs (n: v: v != null) config.nixpkgs));
 
+    configuration = { config, lib, ... }: {
+      imports = [ confPath ];
       lib.depot = depot;
+
+      # home-manager exposes no API to override the package set that
+      # is used, unless called from the NixOS module.
+      #
+      # To get around it, the module argument is overridden here.
+      _module.args.pkgs = mkForce pkgs;
     };
   });