about summary refs log tree commit diff
path: root/users/grfn/system/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/system/home/default.nix')
-rw-r--r--users/grfn/system/home/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/users/grfn/system/home/default.nix b/users/grfn/system/home/default.nix
new file mode 100644
index 0000000000..1efba3f3c1
--- /dev/null
+++ b/users/grfn/system/home/default.nix
@@ -0,0 +1,34 @@
+{ pkgs, depot, lib, ... }:
+
+with lib;
+
+rec {
+  home = confPath: (import "${pkgs.home-manager.src}/modules" {
+    inherit pkgs;
+    configuration = { config, lib, ... }: {
+      imports = [confPath];
+
+      _module.args.pkgs = mkForce
+        (import pkgs.path (filterAttrs (n: v: v != null) config.nixpkgs));
+
+      lib.depot = depot;
+    };
+  });
+
+  chupacabra = home ./machines/chupacabra.nix;
+
+  chupacabraHome = chupacabra.activation-script;
+
+  dobharchu = home ./machines/dobharchu.nix;
+
+  dobharchuHome = dobharchu.activation-script;
+
+  yeren = home ./machines/yeren.nix;
+
+  yerenHome = yeren.activation-script;
+
+  meta.targets = [
+    "chupacabraHome"
+    "yerenHome"
+  ];
+}