about summary refs log tree commit diff
path: root/users/grfn/resume/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/resume/default.nix')
-rw-r--r--users/grfn/resume/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/users/grfn/resume/default.nix b/users/grfn/resume/default.nix
new file mode 100644
index 0000000000..2db6a650bc
--- /dev/null
+++ b/users/grfn/resume/default.nix
@@ -0,0 +1,37 @@
+{ pkgs, ... }:
+
+with pkgs.lib;
+
+pkgs.runCommandNoCC "resume.pdf" {
+  buildInputs = [(pkgs.texlive.combine {
+    inherit (pkgs.texlive)
+      capt-of
+      collection-fontsrecommended
+      enumitem
+      etoolbox
+      fancyvrb
+      float
+      fncychap
+      framed
+      l3packages
+      microtype
+      needspace
+      parskip
+      scheme-basic
+      tabulary
+      titlesec
+      ulem
+      upquote
+      varwidth
+      wrapfig
+      xcolor
+      ;
+  })];
+} ''
+  cp ${builtins.filterSource (path: type:
+    type == "regular" &&
+    any (ext: hasSuffix ext path) [".sty" ".cls" ".tex" ".png"]
+  ) ./.}/* .
+  pdflatex ./resume.tex
+  cp resume.pdf $out
+''