about summary refs log tree commit diff
path: root/users/grfn/keyboard/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/keyboard/default.nix')
-rw-r--r--users/grfn/keyboard/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/users/grfn/keyboard/default.nix b/users/grfn/keyboard/default.nix
index 39b21b8766..929ec7d628 100644
--- a/users/grfn/keyboard/default.nix
+++ b/users/grfn/keyboard/default.nix
@@ -32,6 +32,16 @@ rec {
     AVR_CFLAGS = [
       "-isystem ${avrlibc}/avr/include"
       "-L${avrlibc}/avr/lib/avr5"
+      # GCC 12 has improved array-bounds warnings, failing the build of QMK.
+      # Newer versions of the firmware would work probably, but they heavily
+      # altered the build system, so it is non-trivial. Backporting the patch
+      # that fixes it seems difficult – the next change to the offending matrix.c
+      # after the pinned qmkSource commit is
+      # https://github.com/qmk/qmk_firmware/commit/11c308d436180974b7719ce78cdffdd83a1302c0
+      # which heavily changes the way the code works.
+      #
+      # TODO(grfn): address this properly
+      "-Wno-error=array-bounds"
     ];
 
     AVR_ASFLAGS = AVR_CFLAGS;