about summary refs log tree commit diff
path: root/users/grfn/gws.fyi/orgExportHTML.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/gws.fyi/orgExportHTML.nix')
-rw-r--r--users/grfn/gws.fyi/orgExportHTML.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/users/grfn/gws.fyi/orgExportHTML.nix b/users/grfn/gws.fyi/orgExportHTML.nix
index ac28580a59..f9cb8d38fb 100644
--- a/users/grfn/gws.fyi/orgExportHTML.nix
+++ b/users/grfn/gws.fyi/orgExportHTML.nix
@@ -25,15 +25,16 @@ let
   outName =
     if isNull headline
     then
-      let bn = builtins.baseNameOf src;
-          filename = elemAt (splitString "." bn) 0;
+      let
+        bn = builtins.baseNameOf src;
+        filename = elemAt (splitString "." bn) 0;
       in
-        if depot.nix.utils.isDirectory src
-        then filename
-        else filename + ".html"
+      if depot.nix.utils.isDirectory src
+      then filename
+      else filename + ".html"
     else "${filename}-${replaceStrings [" "] ["-"] filename}.html";
 
-  escapeDoubleQuotes = replaceStrings ["\""] ["\\\""];
+  escapeDoubleQuotes = replaceStrings [ "\"" ] [ "\\\"" ];
 
   navToHeadline = optionalString (! isNull headline) ''
     (search-forward "${escapeDoubleQuotes headline}")