about summary refs log tree commit diff
path: root/users/grfn/gws.fyi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/gws.fyi/default.nix')
-rw-r--r--users/grfn/gws.fyi/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/users/grfn/gws.fyi/default.nix b/users/grfn/gws.fyi/default.nix
new file mode 100644
index 0000000000..ef3ef6c570
--- /dev/null
+++ b/users/grfn/gws.fyi/default.nix
@@ -0,0 +1,31 @@
+args@{ pkgs, ... }:
+with pkgs;
+let
+  site = import ./site.nix args;
+  resume = import ../resume args;
+  bucket = "s3://gws.fyi";
+  distributionID = "E2ST43JNBH8C64";
+
+  css = runCommand "main.css" {
+    buildInputs = [ pkgs.minify ];
+  } ''
+    minify --type css < ${./main.css} > $out
+  '';
+
+  website =
+    runCommand "gws.fyi" { } ''
+      mkdir -p $out
+      cp ${css} $out/main.css
+      cp ${site.index} $out/index.html
+      cp ${resume} $out/resume.pdf
+    '';
+
+in (writeShellScript "deploy.sh" ''
+  ${awscli}/bin/aws --profile personal s3 sync ${website}/ ${bucket}
+  ${awscli}/bin/aws --profile personal cloudfront create-invalidation \
+    --distribution-id "${distributionID}" \
+    --paths "/*"
+  echo "Deployed to http://gws.fyi"
+'') // {
+  inherit website;
+}