about summary refs log tree commit diff
path: root/users/grfn/gws.fyi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/gws.fyi/default.nix')
-rw-r--r--users/grfn/gws.fyi/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/users/grfn/gws.fyi/default.nix b/users/grfn/gws.fyi/default.nix
index 5b7d8fc0e1..5ab3614d79 100644
--- a/users/grfn/gws.fyi/default.nix
+++ b/users/grfn/gws.fyi/default.nix
@@ -6,13 +6,14 @@ let
   bucket = "s3://gws.fyi";
   distributionID = "E2ST43JNBH8C64";
 
-  css = runCommand "main.css" {
-    buildInputs = [ pkgs.minify ];
-  } ''
+  css = runCommand "main.css"
+    {
+      buildInputs = [ pkgs.minify ];
+    } ''
     minify --type css < ${./main.css} > $out
   '';
 
-  keys = runCommand "ssh-keys" {} ''
+  keys = runCommand "ssh-keys" { } ''
     touch $out
     echo "${depot.users.grfn.keys.main}" >> $out
   '';
@@ -27,7 +28,8 @@ let
       cp ${keys} $out/keys
     '';
 
-in (writeShellScript "deploy.sh" ''
+in
+(writeShellScript "deploy.sh" ''
   ${awscli2}/bin/aws --profile personal s3 sync ${website}/ ${bucket}
   echo "Deployed to http://gws.fyi"
 '') // {