about summary refs log tree commit diff
path: root/users/grfn/bbbg/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/grfn/bbbg/shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/grfn/bbbg/shell.nix b/users/grfn/bbbg/shell.nix
new file mode 100644
index 0000000000..195562519e
--- /dev/null
+++ b/users/grfn/bbbg/shell.nix
@@ -0,0 +1,20 @@
+let
+ depot = import ../../.. {};
+in
+with depot.third_party.nixpkgs;
+
+mkShell {
+  buildInputs = [
+    arion
+    depot.third_party.clj2nix
+    clojure
+    openjdk11_headless
+    postgresql_12
+    nix-prefetch-git
+  ];
+
+  PGHOST = "localhost";
+  PGUSER = "bbbg";
+  PGDATABASE = "bbbg";
+  PGPASSWORD = "password";
+}