about summary refs log tree commit diff
path: root/users/grfn/achilles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/grfn/achilles/default.nix')
-rw-r--r--users/grfn/achilles/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/grfn/achilles/default.nix b/users/grfn/achilles/default.nix
new file mode 100644
index 0000000000..4ad71455d4
--- /dev/null
+++ b/users/grfn/achilles/default.nix
@@ -0,0 +1,20 @@
+{ depot, pkgs, ... }:
+
+depot.third_party.naersk.buildPackage {
+  src = ./.;
+
+  buildInputs = with pkgs; [
+    clang_11
+    llvmPackages.llvm
+    llvmPackages.bintools
+    llvmPackages.clang
+    llvmPackages.libclang.lib
+    zlib
+    ncurses
+    libxml2
+    libffi
+    pkgconfig
+  ];
+
+  doCheck = true;
+}