about summary refs log tree commit diff
path: root/users/glittershark/xanthous/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/glittershark/xanthous/shell.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/users/glittershark/xanthous/shell.nix b/users/glittershark/xanthous/shell.nix
index 491f0779f8..dd747b740c 100644
--- a/users/glittershark/xanthous/shell.nix
+++ b/users/glittershark/xanthous/shell.nix
@@ -5,13 +5,11 @@
 })).shellFor {
   packages = p: [p.xanthous];
   withHoogle = true;
+  doBenchmark = true;
   buildInputs = with pkgs.haskellPackages; [
     cabal-install
     ghc-prof-flamegraph
     hp2pretty
-  ];
-
-  nativeBuildInputs = [
-    (import ./hie.nix { inherit pkgs; })
+    pkgs.haskell-language-server.ghc883
   ];
 }