about summary refs log tree commit diff
path: root/users/glittershark/xanthous/pkg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/xanthous/pkg.nix')
-rw-r--r--users/glittershark/xanthous/pkg.nix15
1 files changed, 3 insertions, 12 deletions
diff --git a/users/glittershark/xanthous/pkg.nix b/users/glittershark/xanthous/pkg.nix
index 91de68ea32..fc303a3eda 100644
--- a/users/glittershark/xanthous/pkg.nix
+++ b/users/glittershark/xanthous/pkg.nix
@@ -1,16 +1,7 @@
-{ pkgs ? import ./nixpkgs.nix {} }:
-let
-  inherit (builtins) filterSource elem not;
-  gitignoreSource = (import (pkgs.fetchFromGitHub {
-    owner = "hercules-ci";
-    repo = "gitignore";
-    rev = "f9e996052b5af4032fe6150bba4a6fe4f7b9d698";
-    sha256 = "0jrh5ghisaqdd0vldbywags20m2cxpkbbk5jjjmwaw0gr8nhsafv";
-    # date = 2019-09-18T15:15:15+02:00;
-  }) { inherit (pkgs) lib; }).gitignoreSource;
-in
+{ pkgs ? (import ../../../. {}).third_party }:
+
 import (pkgs.haskellPackages.haskellSrc2nix {
   name = "xanthous";
-  src = gitignoreSource ./.;
+  src = pkgs.gitignoreSource ./.;
   extraCabal2nixOptions = "--hpack";
 })