about summary refs log tree commit diff
path: root/users/glittershark/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/xanthous/default.nix')
-rw-r--r--users/glittershark/xanthous/default.nix24
1 files changed, 5 insertions, 19 deletions
diff --git a/users/glittershark/xanthous/default.nix b/users/glittershark/xanthous/default.nix
index c4260fe258..0b89a50afb 100644
--- a/users/glittershark/xanthous/default.nix
+++ b/users/glittershark/xanthous/default.nix
@@ -1,21 +1,7 @@
-{ nixpkgs ? import ./nixpkgs.nix {}
-, pkgs ? nixpkgs.pkgs
-, lib ? nixpkgs.lib
-, compiler ? "ghc865"
-, failOnWarnings ? false
+{ pkgs ? (import ../../../. {}).third_party
+, lib ? pkgs.lib
 , ...
 }:
-let
-  inherit (lib) id;
-  inherit (pkgs) fetchurl;
-  all-hies = import (fetchTarball {
-    url = "https://github.com/infinisil/all-hies/archive/4b6aab017cdf96a90641dc287437685675d598da.tar.gz";
-    sha256 = "0ap12mbzk97zmxk42fk8vqacyvpxk29r2wrnjqpx4m2w9g7gfdya";
-  }) {};
-  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
-  xanthous =
-    (if failOnWarnings then pkgs.haskell.lib.failOnAllWarnings else id)
-      ((pkgs.haskellPackages
-      # .extend (import ./haskell-overlay.nix { inherit pkgs; })
-    ).callPackage (import ./pkg.nix { inherit pkgs; }) {}); in
-xanthous // { inherit hie; }
+pkgs.haskell.lib.failOnAllWarnings (
+  pkgs.haskellPackages.callPackage (import ./pkg.nix { inherit pkgs; }) {}
+)