about summary refs log tree commit diff
path: root/users/glittershark/xanthous/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/xanthous/default.nix')
-rw-r--r--users/glittershark/xanthous/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/glittershark/xanthous/default.nix b/users/glittershark/xanthous/default.nix
new file mode 100644
index 0000000000..0d08d7f26b
--- /dev/null
+++ b/users/glittershark/xanthous/default.nix
@@ -0,0 +1,19 @@
+{ nixpkgs ? import ./nixpkgs.nix {}
+, compiler ? "ghc865"
+, failOnWarnings ? false
+}:
+let
+  inherit (nixpkgs) pkgs lib;
+  inherit (lib) id;
+  inherit (pkgs) fetchurl;
+  all-hies = import (fetchTarball {
+    url = "https://github.com/infinisil/all-hies/archive/4b6aab017cdf96a90641dc287437685675d598da.tar.gz";
+    sha256 = "0ap12mbzk97zmxk42fk8vqacyvpxk29r2wrnjqpx4m2w9g7gfdya";
+  }) {};
+  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
+  xanthous =
+    (if failOnWarnings then pkgs.haskell.lib.failOnAllWarnings else id)
+      ((pkgs.haskellPackages
+      .extend (import ./haskell-overlay.nix { inherit nixpkgs; })
+    ).callPackage (import ./pkg.nix { inherit nixpkgs; }) {}); in
+xanthous // { inherit hie; }