about summary refs log tree commit diff
path: root/users/glittershark/system/system/modules/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/system/modules/tvl.nix')
-rw-r--r--users/glittershark/system/system/modules/tvl.nix20
1 files changed, 12 insertions, 8 deletions
diff --git a/users/glittershark/system/system/modules/tvl.nix b/users/glittershark/system/system/modules/tvl.nix
index 5fb044b901..36ecd4ccdd 100644
--- a/users/glittershark/system/system/modules/tvl.nix
+++ b/users/glittershark/system/system/modules/tvl.nix
@@ -1,14 +1,18 @@
 { config, lib, pkgs, ... }:
 
 {
-  nix.buildMachines = [{
-    hostName = "whitby.tvl.fyi";
-    sshUser = "grfn";
-    sshKey = "/root/.ssh/id_rsa.whitby";
-    system = "x86_64-linux";
-    maxJobs = 64;
-    supportedFeatures = ["big-parallel"];
-  }];
+  nix = {
+    buildMachines = [{
+      hostName = "whitby.tvl.fyi";
+      sshUser = "grfn";
+      sshKey = "/root/.ssh/id_rsa.whitby";
+      system = "x86_64-linux";
+      maxJobs = 64;
+      supportedFeatures = ["big-parallel"];
+    }];
+
+    binaryCaches = ["ssh://grfn@whitby.tvl.fyi"];
+  };
 
   programs.ssh.knownHosts.whitby = {
     hostNames = [ "whitby" "whitby.tvl.fyi" "49.12.129.211"];