about summary refs log tree commit diff
path: root/users/glittershark/system/system/machines/chupacabra.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/system/machines/chupacabra.nix')
-rw-r--r--users/glittershark/system/system/machines/chupacabra.nix18
1 files changed, 15 insertions, 3 deletions
diff --git a/users/glittershark/system/system/machines/chupacabra.nix b/users/glittershark/system/system/machines/chupacabra.nix
index 5a7c00fc68..65e93507ce 100644
--- a/users/glittershark/system/system/machines/chupacabra.nix
+++ b/users/glittershark/system/system/machines/chupacabra.nix
@@ -1,14 +1,13 @@
 { config, lib, pkgs, ... }:
 {
   imports = [
-    <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
     ../modules/common.nix
     ../modules/reusable/battery.nix
-    <nixos-hardware/common/cpu/intel>
-    <nixos-hardware/common/pc/laptop>
     ../modules/tvl.nix
   ];
 
+  hardware.enableRedistributableFirmware = true;
+
   networking.hostName = "chupacabra";
 
   powerManagement = {
@@ -78,4 +77,17 @@
   powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
   # High-DPI console
   console.font = lib.mkDefault "${pkgs.terminus_font}/share/consolefonts/ter-u28n.psf.gz";
+
+  # from nixos-hardware TODO sort this around
+  services.tlp.enable = true;
+  boot.kernel.sysctl."vm.swappiness" = 1;
+  services.fstrim.enable = lib.mkDefault true;
+
+  # Intel cpu stuff
+  hardware.opengl.extraPackages = with pkgs; [
+    vaapiIntel
+    vaapiVdpau
+    libvdpau-va-gl
+    intel-media-driver
+  ];
 }